Author Topic: Unrealistic expectations?  (Read 449 times)

0 Members and 1 Guest are viewing this topic.

November 29, 2017, 02:32:10 PMReply #15 on

Offline t4tiger (OP)

  • Felis Domesticus
  • Location: York, North Yorkshire
  • Posts: 76
  • Activity Meter:
    0%
  • LOCATION: York, England
Not sure if I've confused the issue.  He replaced 10173 with 10121 and then started changing various numbers, particularly on the a/f screen.  I've called that adjusting the map.  Is that the same as you call piggybacking?

November 29, 2017, 04:05:33 PMReply #16 on

Offline Chris Canning

  • Sumatran Tiger
  • *
  • Location: Birmingham England
  • Posts: 4077
  • Activity Meter:
    0%
  • Bike model currently owned: Tiger 955/1100s/XT660X/K1200r Sport/KTMGT/S1000XR
Nope piggyback is wireing in another device to overrule the ECU ie either a Power Commander or Rapidbike.

I’ve two bikes that have Power Commanders and the Maps they run are as good as the day they were set up on the Dyno in some ways Triumph were ahead of their time because of you being able to access the ECU with various maps but a dead cert it ain’t.

There’s one major problem you can put what ever map and mod you like into the ECU it has a mind of its own and the one thing you can be sure of it won’t stay that way.

Hence why I said i’m Intrigued apart from some years ago when  folks would bodge a PC off a 955 Daytona onto a Tiger I can’t recall anyone having one on a dyno let alone someone comercialy using Tune ECU.

Just to show what can be done I have a K1200 with a Rexxer map no piggy back just an aftermarket map blown into the ECU similar to what can be done with the Tiger but the map doesn’t Go wandering off and doing its own thing like the Triumph offering does,but please carry on i’d Say several of us on here will be interested in what you are doing.

December 01, 2017, 11:19:15 AMReply #17 on

Offline Bixxer Bob

  • Auditor of Reality
  • Moderator
  • Chatty Cathy
  • *
  • Location: Norfolk, England
  • Posts: 6040
  • Activity Meter:
    0%
  • I make the mistakes so you don't have to.....
  • LOCATION: Norfolk, England
  • Bike model currently owned: 2013 Exploder
If he changed table values and it ran great, but now it doesn't, that points to the ECU trimming it away from the table value.  The table value stays the same but the unseen trim table changes it.  Which points to him having re-connected the O2 sensor. 

To try to help, this is how it works.  All the O2 bypass does is provide a resistor (4.7k ohm if I remember right but don't quote me) so the ECU sees the expected 0.46v return from the O2 sensor and so thinks all is well.

If you disconnect the Bypass but don't connect the O2 sensor the ECU sees an open circuit, logs a fault code and illuminates the MIL light.

So either your tech re-connected the O2 sensor , which is what I think happened because the bike is behaving exactly as it would with it connected, ie, great after a new map but trims itself till it's back to being jerky at low throttle, or something weird is going on. That could be either a faulty ECU ( in which case I'd expect other thing s to be wrong too) or you have a high resistance short that is fooling the ECU that the O2 is connected.  There isn't any way to change the ECU software to turn off the MIL light if the O2 plug isn't connected to something.  Just thought while I was typing this, the MIL light does work though, doesn't it???? We're not looking at a blow lamp or wiring fault on the MIL circuit?

Looking at it mnore widely, the ECU delivers the fuel air mixture in a ratio defined by the map tables stored in it depending on engine speed, air and engine temp, air pressure, throttle position and engine load. The values in the map tables are tweaked to some extend by a set of trim values.  The only trim values visible in Tune ECU are the LTFT which should normally never need changing, the warmup tickover setting and IACV setting (not really trims but are adjustable so worth mentioning), and the base value for the injectors which should never be touched unless you really know what you are doing because serious damage can result.  In this state when the map is fresh the bike will run great.  But over time things that can affect the fuelling can change, resulting in a rich or weak mix.  Rich wastes fuel, weak can cause damage, so the ECU has a set of base values that it expects to see from the O2 sensor and adjusts the fuelling based on these.

How the ECU uses the O2 sensor when riding, in simple terms, is like this.  When a set of circumstances are met (engine temp, gear selection, clutch position, idle etc) the ECU reads the voltage return from the O2 sensor.  If the exhaust gas is correct the sensor will return 0.46v and nothing happens.  If the exhaust gas is rich so there is little O2 present the O3 sensor will rise to around 0.9v.  The ECU sees that and trims the mixture lean in small steps to compensate.  Similarly, if the exhaust gas is lean, the O2 sensor will return 0.1v, the ECU will read that and trim the mixture slightly richer to compensate.

From that you can see that the O2 sensor plays an important part in how the ECU controls the fueling as the bike is used.  Your Tech's statement that all the Bypass does is stop the MIL light coming on is ok as far as it goes, but the act of disconnecting the O2 sensor has a much more far-reaching effect. 

There are a few things that can affect this whole delicately balanced setup.

You've already eliminated the IACV hoses so we'll leave that there.
Atmospheric pressure sensor fault.
Air temp sensor fault.
Engine temp sensor fault.
Throttle position sensor fault.
O2 Sensor fault.
Plugs.
Coils.
Airbox leaks.
Exhaust header leaks.

Any of these can affect whether the exhaust gas is rich or lean compared with an expected value and thus cause the ECU to trim accordingly when, in actual fact there may be a fault to fix.  The most common is the IACV hose air leak causing the mix to be lean and the ECU trying to correct that but can't and leads to a massively rich setting.

Don't get me wrong, I'm not rubbishing your dyno man or anyone else, but this is a 16 yr old system that was designed when a lot of Triumph techs were still at school.  Hell, our local Triumph dealer won't fault find on these old bikes now because none of the young(ish) techs were ever taught how they work.  A base knowledge will save you time searching for something that isn't there and help you look in the right places.

I'm thinking about this as I'm writing, and it occurs to me that if you have a fault on one of the items listed, and the O2 is disonnected, the tech could have trimmed out the fault using the tables, however, the only way it could go off again is for the fault to be getting worse.  My money is still on the O2 having been re- connected, with the caviat that I'm doing this with a very very long screwdriver and I can't do my own fault inding.
I don't want to achieve immortality through prayer, I want to achieve it through not dying...

December 01, 2017, 01:58:06 PMReply #18 on

Offline t4tiger (OP)

  • Felis Domesticus
  • Location: York, North Yorkshire
  • Posts: 76
  • Activity Meter:
    0%
  • LOCATION: York, England
Thanks for this. I appreciate the clear explanation.  I can confirm that the O2 sensor is disconnected and there is not an O2 eliminator fitted. The plug is simply cable tied to the frame under the tank.  Mil light works.  O2 sensor fault is noted by tuneecu.  I'll re read this several times and then talk to the Dyno chap. 

December 01, 2017, 08:05:20 PMReply #19 on

Offline Chris Canning

  • Sumatran Tiger
  • *
  • Location: Birmingham England
  • Posts: 4077
  • Activity Meter:
    0%
  • Bike model currently owned: Tiger 955/1100s/XT660X/K1200r Sport/KTMGT/S1000XR
I have never disconnected my 02 it’s either been plugged into the loom or it’s had the spoofer plugged in,but for anyone into aftermarket fuelling will know the merrygoround of 02’s in or out and the two factions are opposed  :icon_biggrin:,my K1200 that has a Rexxer map doesn’t have the 02’s connected its been done via the ECU,and i’m Just about embark on the same journey with my X/R it’s not the aftermarket map that’s the big decision it’s the 02’s in or out.

If there had been a solus piggyback option to bypass the ECU i’d Have done it years ago instead I just shrug my shoulders and let the bloody thing do what it likes within reason  :icon_rolleyes:

December 06, 2017, 01:12:11 PMReply #20 on

Offline Bixxer Bob

  • Auditor of Reality
  • Moderator
  • Chatty Cathy
  • *
  • Location: Norfolk, England
  • Posts: 6040
  • Activity Meter:
    0%
  • I make the mistakes so you don't have to.....
  • LOCATION: Norfolk, England
  • Bike model currently owned: 2013 Exploder
Thanks for this. I appreciate the clear explanation.  I can confirm that the O2 sensor is disconnected and there is not an O2 eliminator fitted. The plug is simply cable tied to the frame under the tank.  Mil light works.  O2 sensor fault is noted by tuneecu.  I'll re read this several times and then talk to the Dyno chap.

I'm looking forward to hearing what he has to say.  This no MIL light situation has me intrigued as I've not come across it before.  Perhaps I'm about to learn something new  :icon_biggrin:  After all, the world was flat until someone proved otherwise  :icon_lol:
I don't want to achieve immortality through prayer, I want to achieve it through not dying...

December 06, 2017, 01:44:09 PMReply #21 on

Offline John Stenhouse

  • Cool Cats
  • Bengal Tiger
  • *
  • Location: Cotswolds, UK
  • Posts: 1924
  • Activity Meter:
    0%
Yeah, but that was easy  :icon_lol:

Anyway if the world was flat, cats would have pushed everything off by now!
Black 885i Tiger UK based
Orange 955i Tiger Canadian based
Norton 961S never got it, tired of waiting

 


SimplePortal 2.3.7 © 2008-2022, SimplePortal