TigerTriple.com

Tiger Time => Girly Talk (1999 - 2006 Tigers) => Topic started by: CharlieF1 on June 06, 2021, 05:25:40 AM

Title: Coolant temperature sensor clip installation
Post by: CharlieF1 on June 06, 2021, 05:25:40 AM
This is my first post, had not needed help before today! So hoping the collective brain trust can assist with my 2006 Girly repair issue.

I had to replace the right hand half of the thermostat housing due to a crack in the plastic where one of the hoses attaches. NOTE! The housing parts are now totally unavailable, Triumph stopped shipping them about 5 years ago, but I found one of the last on earth on eBay last week, for a mere $40. It was listed for a 2001, but my parts guy at Hermy's said they are all the same. He's right.

In the process I also had to remove the coolant temperature sensor and put it into the new housing half. However, there is a simple but diabolical U-shaped clip that goes through a slot to keep the sensor in place. It comes out SO EASY, but I've found it almost impossible to put it back in. It is inserted into the slot, then supposedly forced past the metal sensor body and the open legs are then supposed to find a new home in the opposing slot. Brilliant.

I've ground a little metal off the sides of the pointy ends, and am considering grinding some of the plastic inside between the two slots to give the clip a little more room to move, and I might. But before I do, and possibly compromise the last part I'm likely to find for sale, I wonder if anyone has encountered this problem before and has any tips on how to get it back into place without machining or possibly explosives?

Photo attached.

Thanks much,
Charlie
Title: Re: Coolant temperature sensor clip installation
Post by: ghulst on June 06, 2021, 09:17:08 PM
I would love to see you solve that with explosives...

Other than that, I don't have any real suggestions, but couldn't help myself. ;) It usually is something stupid like perseverance, but something simple would be nice in this case.
Title: Re: Coolant temperature sensor clip installation
Post by: CharlieF1 on June 06, 2021, 11:04:09 PM
Hello sir,

I have not ridden the bike since last October. It's summer  :* and I have time on my hands and I'm done with trying to maintain a perfect factory install. So after fretting over this for far too many hours, I've resorted to the tried and true "workaround." The Dremel grinder stayed in the tool box. The silly-assed Triumph clip goes into the parts box and a pair of cotter pins are now securing the sensor. I plan to be happy with this and if ever I'm not (long term test), I'll update the thread, hopefully not from the side of the road.  :wave

Charlie
Title: Re: Coolant temperature sensor clip installation
Post by: Sin_Tiger on June 07, 2021, 12:02:26 AM
Are you sure the sensor is pushed all the way in Charlie, they can be tight if the O ring is getting on a bit.

I'll probably regret saying this but did you try a smear of vaseline  :tin hat
Title: Re: Coolant temperature sensor clip installation
Post by: CharlieF1 on June 07, 2021, 04:43:12 AM
Hi Sin,

Yes, I could see the old marks on the contact surface of the brass sensor, level with the slots, and it would not go down any further so I think I'm good there.

However, appreciate your idea of the vaseline, and although I didn't use any lube on the o-ring, I know it crossed my mind at one point. I was fighting the fitment of one of the coolant hoses and that won out. Later, at my last opportunity, I reconsidered and thought I'd look for my hi-temp RTV to use instead. That thought too became an escapee at the wrong time, so now it's all back together and awaiting a test ride tomorrow.

A certain amount of anti-freeze started dripping when the motor first lit, but then it stopped so I'm cautiously optimistic. We shall see in the daylight!

Charlie
Title: Re: Coolant temperature sensor clip installation
Post by: VABird on June 07, 2021, 02:15:28 PM
May seem like a silly question, but were you using snap ring pliers for the reinstall?
Title: Re: Coolant temperature sensor clip installation
Post by: CharlieF1 on June 07, 2021, 02:30:13 PM
Nope, although I have them. Unfortunately, this isn't a "real" snap ring. That's why this thing is such a pisser.
Squeezing the clip would have just made it more difficult to push into place. Squeeze in, gets tighter. Squeeze out, the clip digs into the plastic and ... makes it harder to move. A standard lose-lose operation.
 :icon_evil:
SimplePortal 2.3.7 © 2008-2022, SimplePortal